Mail Delivery Issues
Incident Report for MediaSilo
Resolved
Our upstream provider has confirmed that this issue is resolved.
Posted Feb 19, 2020 - 20:37 PST
Monitoring
Our upstream provider has identified the issue and has confirmed that messages should now be delivered as normal. Certain messages may experience a delay as they dequeue previously delayed messages. We are continuing to monitor the situation.
Posted Feb 19, 2020 - 17:32 PST
Identified
We can confirm that system emails are not being delivered due to an issue with an upstream provider. We are working with them to resolve.
Posted Feb 19, 2020 - 16:34 PST
Investigating
We are investigating reports of system emails not being delivered.
Posted Feb 19, 2020 - 16:28 PST
This incident affected: MediaSilo App (Email Delivery).